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Team members who do not need to alter project plans use Seavus Project Viewer to view 

the tasks they have been assigned. But wouldn't it be better to know the progress status 

of each task in real time as well? 

Seavus Project Viewer is the only viewer for Microsoft® Project that provides a 

collaborative environment for project teams without server installation. 

The process of sharing is very simple: 

 The project manager creates a project plan in Microsoft® Project and uploads it

on a shared location

 Team members open the project plan with Seavus Project Viewer and report task

progress or assignment progress (% Completed, % Work Complete or Actual

Work).

 The project manager then opens the project plan and accepts or rejects

submitted task updates.

Create Project

Update Task or 
Assignment

Accept/Reject

Overview 
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With this very simple task update process, teams can easily introduce a collaborative 

project environment where they can: 

 Get real-time project status

 Continually evaluate team's performance

 Build knowledge for future projects

The project’s categories that are available for updating are presented on the diagram 

below: 

Assignment update 

Team Members can update the assignments in the project plan using the Resource Usage 

or Task Usage view. Project Manager will view this updates using the “Get Updates” 

functionality in Microsoft Project that is already developed, accept or reject them and the 

project plan will be updated. 

Task Update 

Team Members can update the assignments in the project plan using the Gantt Chart view 

and the fields that are prepared for this purpose. Project Manager will view this updates 

using the “Show Updates in Gantt Chart” functionality in the Gantt Chart tablet that will be 

developed. 

Task Update 
Feature

Assignment 
Update

Resource 
Usage view

Task Usage 
view

Task Update

Gantt Chart 
views

Custom Text 
Update

Gantt Chart 
views
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In this section you will learn: 

 Detailed features of the entire application

Introduction 

With Task Update option in Seavus Project Viewer the users now have the ability to 

collaborate with project managers so they will have up-to-date information about the 

current status of the project tasks and track if all assignments in the project plan are 

finished on time. Team members that are using Seavus Project Viewer and Project 

Managers using Microsoft Project can collaborate with only shared location in their 

company’s network. 

In order to use task update you must have: 

 Seavus Project Viewer with Task Update feature installed on your computer;

 Microsoft Project and Seavus Add-in for Microsoft Project installed on Manager’s

Computer, file previously marked as collaborative by project manager, located on a

shared location;

 Read/write permissions to the shared location.

Benefits from Task Update 

Since collaboration between the Project Manager and his Team members is essential for 

successfully running projects, Seavus Project Viewer Task Update can be great tool for 

reaching this goal.  

Chapter 1.: Introduction 

to Task Update
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Seavus Project Viewer Task Update can help companies to decrease their costs, easily track 

their projects and have better overview of their projects.  

Moreover, you can avoid useless e-mail communication with your project manager. 
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In this section you will learn: 

 About the Task Update ribbon

 How to update task and assignments

Task Update ribbon 

Task Update ribbon is a dynamic ribbon that appears next to the “View” ribbon when the 

Task Update add-in is installed within Seavus Project Viewer™. It contains set of functions 

that allows users to update tasks and assignments, insert or delete comments regarding 

their daily activities, view the comments that are inserted by project managers, etc. 

Figure 1. Task Update ribbon in Seavus Project Viewer™ 

Collaboration group 

The look of the Collaboration group in the Compare Project ribbon is presented on the 

figure below: 

2.Chapter : Seavus Project 

Viewer Task Update 

Chapter 2: Seavus Project ViewerTM Task Update 



Page | 7 

Seavus Project ViewerTM User Manual 

Figure 2. Collaboration group in Task Update ribbon 

The features that are implemented in Collaboration group are: 

Feature Description 
Collaboration Mode Turn on/Turn off the collaboration feature within Seavus 

Project Viewer™ 

Update Method Change the updating method from “Update Assignments” 

into “Update Tasks” and vice versa. When changing the 

updating method, all previously created updates for the 

current update method will be deleted. 

Edit group 

The look of the Edit group in the Task Update ribbon is presented on the figure below: 

Figure 3. Edit group in Task Update ribbon 

The features that are implemented in Edit group are: 

Feature Description 
Copy Selection Copy the value from the selected cell in the Gantt Chart view 

or in Usage views. 

Delete Insert the copied value in the selected field(s). In case of 

multi selection, where fields from different columns are 

selected, the value will be copied in the those fields from 

which the value is copied 

Insert Value Opens the “Insert Value” dialog where you user can insert 

the appropriate value for updating selected task(s) / 

assignment(s) 

Clear All Values Deletes the created updates for selected 

task(s)/assignment(s) 

Reset to Referent 
Values 

Resets all updates to the referent value. 

Chapter 2: Seavus Project ViewerTM Task Update 
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Marked As Completed group 

The look of the Marked As Completed group in the Task Update ribbon is presented on 

the figure below: 

Figure 4. Marked As Completed group in Task Update ribbon 

The features that are implemented in Comments group are: 

Feature Description 
Marked As Completed Marked the assignment as 100% complete, although there 

are still days left for completing it. 

Comments group 

The look of the Comments group in the Task Update ribbon is presented on the figure 

below: 

Figure 5. Comments group in Task Update ribbon 

The features that are implemented in Comments group are: 

Feature Description 
Insert Opens the “Add comments” widow where user can insert its 

comments regarding the task/assignment and reads the 

comments that are inserted by the project manager 

Delete Deletes previously inserted comments for the 

task/assignment 

Chapter 2: Seavus Project ViewerTM Task Update 
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Creating Updates 

When you are opening a project file from a shared location, if collaboration is enabled on 

it, you should get a popup asking you how you would like to open the file. You have two 

options: 

 Collaboration mode – if you choose this option you’ll be able to create you

updates.

 Standard mode – if you choose this option your project plan will be opened

without editing options.

Figure 6. Collaboration dialog 

If you have opened the project file in one mode and you want to change the mode while 

working, you can always select or unselect the Collaboration mode option.  

If you are working in Ribbon Graphic User Interface, the option for activating/deactivating 

the Collaboration mode is located in the Task Update ribbon, in the Collaboration group, 

as it is presented on Figure 7. 

Figure 7. Collaboration option in Seavus Add-in ribbon 

In case you are working with Standard Graphic User Interface, the position of this feature 

in the Tools menu is presented on Figure 8. 

Chapter 2: Seavus Project ViewerTM Task Update 
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Figure 8. Collaboration option in Tools menu 

After you have opened the project file in Collaboration mode, you can create your updates 

by using either the Resource/Task Usage views or Gantt Chart.  

Updating Assignments 

Updating Assignments process is performed on those assignments for which the resources 

are selected from the dialog box that is presented on Figure 9.  

Figure 9. Selecting resources and time range 

Chapter 2: Seavus Project ViewerTM Task Update 
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You can report time and progress on working days beginning from the start date of the 

project till the finish date of the project. The updating can be done in %Work complete or 

Actual Work and/or Actual Overtime Work. 

With Seavus Project Viewer Task Update your project plan is flexible enough, so you don’t 

have to worry about missing a day out of work or forgetting to send updates.  

 You can report more work than the planned work and planned overtime work for

the proper day.

 You can report time or progress for incoming days or for days in the past, out of

the task’s time range.

 You can report overtime work even if your project manager did not planned

overtime work.

 You cannot create updates out of project’s time range. Your updates must be

within the start and end date of the project.

 You cannot report %Work complete smaller than 0% or bigger than 100%.

 You can report time or progress on tasks that has no assigned resource

(Unassigned tasks)

 The updates can be created only on work resources.

 You can insert comments regarding the updates

Updating via Task Usage and Resource Usage Views 

After you have opened the project from the shared location you can start making updates. 

Resource and Task Usage views contain two types of fields: 

 General assignment fields in the left panel

 Time phased fields in the right usage panel.

If using collaborative project file you will be able to edit %Work complete in the left panel 

or Actual Work and Actual Overtime Work (time-phased) in the right usage panel. 

Updating % Work Complete 

You can update % Work Complete using the table sheet in the Task or Resource Usage 

view, as it is presented on Figure 10.  

Chapter 2: Seavus Project ViewerTM Task Update 
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Figure 10. Updating % Work Complete 

The process of updating assignment’s % Work Complete is more than easy. Just perform 

the following steps: 

1. Select the assignment that you want to update

2. Click with the mouse in the appropriate cell of the % Work Complete column

3. Using the cell’s spinner ( ) navigate to the desired value or type it in the cell 

4. Save the updates (FileSave)

Besides updating the assignment through table field, you can update the assignment(s) 

trough “Insert Value”  feature, which is located within the Task Update ribbon. After 

clicking on the icon, new dialog will appear where you can insert the appropriate value. 

Figure 11. Insert value dialog 

Updating Actual Work 

Updating the Actual Work and Actual Overtime work is done in the right part of the 

Resource Usage or Task Usage view, as it is presented on Figure 12.  

Chapter 2: Seavus Project ViewerTM Task Update 
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Figure 12. Updating Actual Work 

To update assignment’s Actual Work and/or Actual Overtime Work follow the next 

procedure: 

1. Select the assignment that you want to update

2. Click with the mouse in the appropriate cell of the Actual Work and/or Actual

Overtime Work row in the time-phase data

3. Insert the appropriate value in the cell

4. Save the updates (FileSave)

Updating Tasks 

Updating Tasks from the project plans starts with the dialog presented on Figure 13: 

Figure 13. Select tasks 

Chapter 2: Seavus Project ViewerTM Task Update 
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After selecting the tasks form the dialog, you can report progress on project’s tasks using 

the following available fields: % Complete, % Work Complete, Actual Work and Actual 

Start/Actual Finish. 

With Seavus Project Viewer Task Update your project plan is flexible enough, so you don’t 

have to worry about missing a day out of work or forgetting to send updates.  

 You cannot report % Complete and Work complete smaller than 0% or bigger

than 100%.

 You can report time or progress for incoming days or for days in the past, out of

the task’s time range.

 You cannot create updates out of project’s time range. Your updates must be

within the start and end date of the project.

 You can insert comments regarding the updates

Updating via Gantt Chart Views 

After you have opened the project from the shared location you can start making updates. 

Gantt Chart views contain only one category of fields: 

 General task fields in the left panel

If using collaborative project file you will be able to edit % Complete, % Work complete 

and Actual Work in the left working panel i.e. in the Gantt Chart table. 

Updating % Complete 

You can update % Complete using the table sheet in the Gantt Chart view, as it is 

presented on Figure 14. 

Figure 14. Update % Complete 

Chapter 2: Seavus Project ViewerTM Task Update 
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The process of updating assignment’s % Work Complete is more than easy. Just perform 

the following steps: 

1. Select the task that you want to update

2. Click with the mouse in the appropriate cell of the “% Complete” column

3. Using the cell’s spinner ( ) navigate to the desired value or type it in the cell 

4. Save the updates (FileSave)

Besides updating the assignment through table field, you can update the assignment(s) 

trough “Insert Value”  feature, which is located within the Task Update ribbon. After 

clicking on the icon, new dialog will appear where you can insert the appropriate value. 

Figure 15. Insert value dialog 

Updating Actual Start/Actual Finish 

When updating task’s dates, you are able to update only one date: either Actual Start Date 

or Actual Finish Date.  

You can update task’s Actual Start/Actual Finish using the table sheet in the Gantt Chart 

view, as it is presented on Figure 23. 

Chapter 2: Seavus Project ViewerTM Task Update 
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Figure 16. Update Actual Start of the task 

The process of updating task’s date is more than easy. Just perform the following steps: 

1. Select the task that you want to update

2. Click with the mouse in the appropriate cell of the Actual Start/Actual Finish column

3. Using the cell’s drop-down ( ) navigate to the desired date

4. Save the updates (FileSave)

Besides updating the assignment through table field, you can update the assignment(s) 

trough “Insert Value”  feature, which is located within the Task Update ribbon. After 

clicking on the icon, new dialog will appear where you can insert the appropriate value. 

Figure 17. Insert value dialog 

Chapter 2: Seavus Project ViewerTM Task Update 



Page | 17 

Seavus Project ViewerTM User Manual 

Updating Duration 

You can update task’s duration using the table sheet in the Gantt Chart view, as it is 

presented on Figure 18. 

Figure 18. Update Actual Duration 

To update task’s duration perform the following steps: 

1. Select the task that you want to update

2. Click with the mouse in the appropriate cell of the Actual Duration column

3. Type the appropriate value

4. Save the updates (FileSave)

Besides updating the assignment through table field, you can update the assignment(s) 

trough “Insert Value”  feature, which is located within the Task Update ribbon. After 

clicking on the icon, new dialog will appear where you can insert the appropriate value. 

Figure 19. Insert value dialog 

Updating Notes 

There are three possibilities to update task’s notes. The first one is updating the notes 

through “Notes” column, much similar like updating the parameters in the Custom Text 

Chapter 2: Seavus Project ViewerTM Task Update 
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Fields columns. Double click on cell from the Notes column, where you want to add note 

and start typing.  

The updating process is presented on Figure 20. 

Figure 20. Insert notes from "Notes" column 

The second process is updating the notes through “Task Information” window. You can 

insert your notes, remarks or additional information regarding the assignments in specially 

designed “Task Update Note” field inside the “Task Information” window.  

The process is as follow: 

1. Double click on the task’s name

2. In the Task Information window select the Notes tab

3. In the Task Update Note field insert your notes

4. Click on the Apply button

5. Save the updates (FileSave)

The look of the Notes tab from the Task Information window is presented on the Figure 

21.

Chapter 2: Seavus Project ViewerTM Task Update 
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Figure 21. Notes tab in the Task Information window 

Finally, task notes can be inserted through “Insert Value”  feature, which is located 

within the Task Update ribbon. After clicking on the icon, new dialog will appear where 

you can insert the appropriate value. 

Figure 22. Insert value dialog 

Insert Comment 

No matter in which update mode you are working, you can insert comments for the 

updates that are inserted. These comments will be sent to the project manager together 

with the assignment’s updates. 

Chapter 2: Seavus Project ViewerTM Task Update 
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Figure 23. Comment menu 

Pointing the mouse cursor over cell and clicking on the right mouse button, a context 

menu will pop-up with the following options (Figure 23): 

 Insert Comments – You can insert comment for the appropriate update, or

give reply to the project manager’s comment 

 Delete Comments – Deleting all comments that are inserted for the

appropriate updates 

 Clear Value – You will delete entire set of information that is connected for

the appropriate assignment (updates and comments) 

The dialog that wills pop-up after you select the Insert Comments feature is presented on 

the figure below. 

Figure 24. Insert Comment dialog 

Chapter 2: Seavus Project ViewerTM Task Update 
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In case when comments exist for the assignment you can edit the comments by selecting 

the Edit comments from the Comment contextual menu. 

Besides inserting comments for the assignment/task through contextual menu, you can 

also insert them trough “Insert comments”  feature, which is located within the Task 

Update ribbon. 

Note: You can’t insert comment until you don’t update the assignment. 

Indicators Column 

By clicking on the icon in the indicators column, you can: 

 Reset to referent values – Your updates will be reset to the referent values they had

before making any changes;

 Clear all values – All of you updates that you made, but did not saved, will be

cleared and you will have the possibility to create new updates;

 Mark assignment as completed – If you finish you task earlier, you can always mark

it as completed. This option will not add hours or percent complete to you task,

but will notify your project manager that your task is finished.

 Change update method – If you started to update an assignment with %Work

complete, the editing fields in the right usage panel will be disabled.

Saving updates 

When you are finished updating, all you have to do is to save your updates. You can do 

that by using the Save functionality inside the Backstage view (File ribbon). 

Chapter 2: Seavus Project ViewerTM Task Update 
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Figure 25. Save Updates functions in Seavus Add-ins ribbon 

The same functionality is located in the File menu: 

Figure 26. Save Updates in File menu 

and in the Standard Toolbar. 

Figure 27. Save Updates in Standard toolbar 

When your updates are saved, your project manager can review and accept or reject them. 
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In this section you will learn: 

 How to update task and assignments

Introduction 

The project plan is created, project’s resources are assigned to the tasks and placed on 

shared location, where the team members have access for viewing and updating. The 

example project plan is the same plan that is described in the “Work with Task Update – 

Project Manager” document. In this chapter, all updated methods will be presented and 

explained. 

Updating Project Tasks 

Updating project tasks is performed using the Gantt Chart view. Team member can choose 

the updating method and give proposal for the task’s progress.  

Updating % Complete 

For updating the % Complete of the task, team member should use the “% Complete” 

column in the Gantt Chart table.  

The process is as follow: 

1. Select the collaboration project file that contains the tasks should be updated.

2. Click on the “Collaboration Mode” button.

3. The first three tasks will be selected for updating.

3.Chapter : Example for 

updating tasks and 

assignments  
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Note: If the team members works with same tasks in defined period of time, with using the 

“Remember selection” check box, the selected tasks will be pre-checked and the opening 

process will be faster.  

4. Select the task with ID 4 in SPV.

5. Click on the Seavus Task Update ribbon, and select the  Update Method feature. 

6. From the drop-down list select the “Task Percent Complete update method”.

Figure 28. 

After opening the project file, moving the “% Complete” column at the beginning of the 

table and choosing the update method, the project file will look like the image below: 



Chapter 3: Example for updating tasks and assignments 

Page | 25 

Seavus Project ViewerTM User Manual 

Figure 29. 

Next step is to insert value in the % Complete cell. Thus: 

1. Double click on the cell for the task with ID 4

2. Insert value for % Complete – 25%.

3. Save the changes (File -> Save)

Note: The presented process is the same when updating the “% Work Complete” 

Update Updating Actual Work 

For updating the Actual Work of the task, team member should use the “Actual Work” 

column in the Gantt Chart table.  

The process is as follow: 

1. Select the collaboration project file that contains the tasks should be updated.

2. Click on the “Collaboration Mode” button.

3. The first three tasks will be selected for updating.
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Note: If the team members works with same tasks in defined period of time, with using the 

“Remember selection” check box, the selected tasks will be pre-checked and the opening 

process will be faster.  

1. Select the task with ID 4 in SPV.

2. Click on the Seavus Task Update ribbon, and select the  Update Method feature. 

3. From the drop-down list select the “Task Actual Work update method”.

Figure 30. 
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After opening the project file, moving the “Actual Work” column at the beginning of the 

table and choosing the update method, the project file will look like the image below: 

Figure 31. 

Next step is to insert value in the Actual Work cell. Thus: 

4. Double click on the cell for the task with ID 4

5. Insert value for Actual Work – 10h.

6. Save the changes (File -> Save)

Update Updating Actual Start 

For updating the Actual Start of the task, team member should use the “Actual Start” 

column in the Gantt Chart table.  
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The process is as follow: 

1. Select the collaboration project file that contains the tasks should be updated.

2. Click on the “Collaboration Mode” button.

3. The first three tasks will be selected for updating.

Note: If the team members works with same tasks in defined period of time, with using the 

“Remember selection” check box, the selected tasks will be pre-checked and the opening 

process will be faster.  

4. Select the task with ID 4 in SPV.

5. Click on the Seavus Task Update ribbon, and select the  Update Method feature. 

6. From the drop-down list select the “Task Actual Start update method”.
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Figure 32. 

After opening the project file, moving the “Actual Start” column at the beginning of the 

table and choosing the update method, the project file will look like the image below: 

Figure 33. 

Next step is to insert value in the Actual Start cell. Thus: 

1. Double click on the cell for the task with ID 4

2. Insert date for Actual Start – 23.12.2013.
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3. Save the changes (File -> Save)

Note: The presented process is the same when updating the “Actual Finish” 

Updating Actual Duration 

For updating the Actual Duration of the task, team member should use the “Actual 

Duration” column in the Gantt Chart table.  

The process is as follow: 

1. Select the collaboration project file that contains the tasks should be updated.

2. Click on the “Collaboration Mode” button.

3. The first three tasks will be selected for updating.
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Note: If the team members works with same tasks in defined period of time, with using the 

“Remember selection” check box, the selected tasks will be pre-checked and the opening 

process will be faster.  

4. Select the task with ID 4 in SPV.

5. Click on the Seavus Task Update ribbon, and select the  Update Method feature. 

6. From the drop-down list select the “Task Actual Duration update method”.

Figure 34. 
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After opening the project file, moving the “Actual Duration” column at the beginning of 

the table and choosing the update method, the project file will look like the image below: 

Figure 35. 

Next step is to insert value in the Actual Duration cell. Thus: 

1. Double click on the cell for the task with ID 4

2. Insert value for Actual Duration – 2d.

3. Save the changes (File -> Save)

Updating Project Assignments 

Updating project tasks is performed using the Resource Usage view. Team member can 

choose the updating method and give proposal for the assignment’s progress. 
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Update % Work Complete 

For updating the % Work Complete of the task, team member should use the “% 

Complete” column in the Task Usage table.  

The process is as follow: 

1. Select the collaboration project file that contains the tasks should be updated.

2. Click on the “Collaboration Mode” button.

3. Select the “HR Manager” and “Product Manager” resources.

Note: If the team members works with same tasks in defined period of time, with using the 

“Remember selection” check box, the selected tasks will be pre-checked and the opening 

process will be faster. 

After opening the project file, the project file will look like the image below: 
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Next step is to insert value in the % Work Complete cell. Thus: 

1. Double click on the “Determine Project Scope” assignment under the Product

Manager resource

2. Insert value for % Work Complete: 39%.

3. Save the changes (File -> Save)
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Update Assignment’s Work 

When updating Assignment’s work team member must choose its name in the 

“Collaboration File” dialog (presented on the image below). In the presented example, 

generis resources are used in the project plan, but in the reality, you will assign real 

resources from your team. The process of updating assignment’s work is identical whether 

there are generic or real resources in the project plan.  

Updating Assignment’s work is based on company’s and team’s working etic, which means 

that every person from the working team updates its own assignments.  

The process is as follow: 

1. Select the collaboration project file that contains the tasks should be updated.

2. Click on the “Collaboration Mode” button.

3. Select the “HR Manager” and “Product Manager” resources.
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After opening the project file, the project file will look like the image below: 

Next step is to insert value in the % Work Complete cell. Thus: 

1. From the “Update Method” button in the Seavus Task Update ribbon, select the

“Assignment Work update method”.

2. For the “Determine Project Scope” assignment under the Product Manager resource

name, the resource enters 4 h for the Actual Work for Monday.

3. For the “Define Preliminary resource” assignment under the Product Manager

resource name, the resource enters 4 h for the Actual Work for Wednesday, and 6 h

for Actual Work for Thursday.
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4. Save the changes (File -> Save)
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